Mercedes CLA Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
17 Posts
Discussion Starter #1
All,

I just had the engine light go on with about 1900 miles on the car and i have a device called Automatic which monitors you cars computer and it threw a code P023812 which is Boost pressure sensor. What was happening is that it was it was shorting out. The did some wiring chasing and found nothing. So they took one off a car in lot and it corrected the problem and then ordered the new sensor for me it took about three days to resolve the issue and I'm not sure if it was isolated issue or going to be a problem for others but i thought i would share my exp. But I'm back up and running so all is good in my world. They also updated the software during trouble shooting but that didn't resolve with out a new sensor.
 

·
Registered
Joined
·
3 Posts
I got a boost pressure code and it caused the care to have reduced power and I had to pull over to the side of the road. In doing so, I almost got hit by two semi trucks and someone threw a coin at my window, chipping it.

I did not get a check engine light. It's at the dealer right now and I will insist they replace this sensor and I have a case open with MB USA. No MB, or any car for that matter, should ever put me on the side of the road at 991 miles and risk my life. MB USA is treating me well so far... we'll see.

My H/K stereo is also distorting like crazy. Terrible.
 

·
Registered
Joined
·
39 Posts
There's an open campaign code 2013110004 -117 ECU Software. MB call me to take it to correct the faults. Ck with you local MB.
 
1 - 3 of 3 Posts
Top