Mercedes CLA Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter · #1 ·
Hi all, has anybody connected their iPod via the media interface connection? I used mine for the first time today and plugged it in up came the Mercedes logo so all good there. Although as soon as I try to use it the connection is awful and it keeps dropping connection, reconnecting and then eventually disconnects completely. During this the Mercedes logo stays on the iPod all the time.
 

·
Registered
Joined
·
21 Posts
I tried with an ancient iPod and then with a slightly less ancient iPhone but neither would work with the media interface. The operator's manual is pretty poor in regards to iPod connectivity, the instructions are basically, "plug it in."

Only thing I can recommend is checking that you're running the right firmware and your device is on the compatibility list.

Mercedes-Benz Bluetooth Connectivity
 

·
Registered
Joined
·
17 Posts
Try someone else's because it might be IPOD or connection but mine works great but only way to know is to try a different iPod.


Hi all, has anybody connected their iPod via the media interface connection? I used mine for the first time today and plugged it in up came the Mercedes logo so all good there. Although as soon as I try to use it the connection is awful and it keeps dropping connection, reconnecting and then eventually disconnects completely. During this the Mercedes logo stays on the iPod all the time.
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #4 ·
Ok thank you both for your feedback. I viewed the Mercedes link and it says I need a iPod classic v6, not sure which mine is but i'll try to find out tonight.

I also tried my iTouch this morning and it worked fine so if I don't have a v6 classis I guess i'll be using the iTouch.
 

·
Premium Member
Joined
·
927 Posts
Ok thank you both for your feedback. I viewed the Mercedes link and it says I need a iPod classic v6, not sure which mine is but i'll try to find out tonight.

I also tried my iTouch this morning and it worked fine so if I don't have a v6 classis I guess i'll be using the iTouch.
When you say iTouch do you mean iPod Touch? I have an older iPod and I can't get it to work with the MB interface either.
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #7 ·
Ok so I think my iPod classic is a 5th gen so it doesn't work very well at all :-( but my iTouch is a ver4 and thankfully that works a treat.

Annoying as hell that my 120GB classic won't work though and I only have 32GB available.
 
1 - 7 of 7 Posts
Top